What’s Vulnerable › Vulnerabilities
CVE-2026-0889: Denial-of-service in the DOM: Service Workers component
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-13 · updated 2026-06-17
- Weakness: CWE-400
Description
Denial-of-service in the DOM: Service Workers component. This vulnerability was fixed in Firefox 147 and Thunderbird 147.
Affected products
- Mozilla Firefox: before 147.0 — fixed in 147.0
- Mozilla Thunderbird: before 147.0 — fixed in 147.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 147.0; Mozilla Thunderbird 147.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1999084
- https://www.mozilla.org/security/advisories/mfsa2026-01/
- https://www.mozilla.org/security/advisories/mfsa2026-04/
Get alerted when CVE-2026-0889 or the next vulnerability affects your stack