What’s Vulnerable › Vulnerabilities
CVE-2026-0930: Potential wolfSSHd Buffer out-of-bounds Read on Windows Handling Terminal Resize
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-20 · updated 2026-10-26
- Weakness: CWE-126
Description
Potential read out of bounds case with wolfSSHd on Windows while handling a terminal resize request. An authenticated user could trigger the out of bounds read after establishing a connection which would leak the adjacent stack memory to the pseudo-console output.
Affected products
- wolfSSL Inc. wolfSSH: from 1.4.15 before 1.5.0 — fixed in 1.5.0
How to fix
Upgrade to a fixed version: wolfSSL Inc. wolfSSH 1.5.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-0930 or the next vulnerability affects your stack