What’s Vulnerable › Vulnerabilities

CVE-2026-0934: Incorrect Authorization in GitLab

Description

GitLab has remediated an issue in GitLab EE affecting all versions from 17.9 before 18.11.6, 19.0 before 19.0.3, and 19.1 before 19.1.1 that under certain conditions could have allowed an authenticated user with custom role permissions to view, create, or delete protected environment configurations despite CI/CD visibility being disabled for the project.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.11.6, 19.0.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-0934 or the next vulnerability affects your stack