What’s Vulnerable › Vulnerabilities
CVE-2026-0966: Libssh: libssh: denial of service via zero-length input in ssh_get_hexa()
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-26 · updated 2026-09-01
- Weakness: CWE-124
Description
A flaw was found in libssh. The API function `ssh_get_hexa()` is vulnerable to a denial of service when processing zero-length input. This can be exploited remotely by an attacker during GSSAPI (Generic Security Service Application Program Interface) authentication if the server's logging verbosity is set to `SSH_LOG_PACKET (3)` or higher. Successful exploitation could lead to a self-Denial of Service of the per-connection daemon process.
Affected products
- libssh: before 0.11.4 — fixed in 0.11.4
- Red Hat Enterprise Linux: 8.0, 9.0, 10.0
- RedHat Hardened Images: all versions
- Red Hat OpenShift Container Platform 4.18: 4.0
How to fix
Upgrade to a fixed version: libssh 0.11.4. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2026:18160
- https://access.redhat.com/errata/RHSA-2026:18683
- https://access.redhat.com/errata/RHSA-2026:7067
- https://access.redhat.com/security/cve/CVE-2026-0966
- https://bugzilla.redhat.com/show_bug.cgi?id=2433121
- https://www.libssh.org/2026/02/10/libssh-0-12-0-and-0-11-4-security-releases/
Get alerted when CVE-2026-0966 or the next vulnerability affects your stack