What’s Vulnerable › Vulnerabilities
CVE-2026-0969: Arbitrary code execution in React server-side rendering of untrusted MDX content
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-12 · updated 2026-06-17
- Weakness: CWE-94
Description
The serialize function used to compile MDX in next-mdx-remote is vulnerable to arbitrary code execution due to insufficient sanitization of MDX content. This vulnerability, CVE-2026-0969, is fixed in next-mdx-remote 6.0.0.
Affected products
- HashiCorp Shared library: from 4.3.0 before 6.0.0 — fixed in 6.0.0
How to fix
Upgrade to a fixed version: HashiCorp Shared library 6.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-0969 or the next vulnerability affects your stack