What’s Vulnerable › Vulnerabilities

CVE-2026-0997: Mattermost Zoom Plugin channel preference API lacks authorization checks

Description

Mattermost versions 11.1.x <= 11.1.2, 10.11.x <= 10.11.9, 11.2.x <= 11.2.1 and Mattermost Plugin Zoom versions <=1.11.0 fail to validate the authenticated user when processing {{/plugins/zoom/api/v1/channel-preference}}, which allows any logged-in user to change Zoom meeting restrictions for arbitrary channels via crafted API requests.. Mattermost Advisory ID: MMSA-2025-00558

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.11.10, 11.1.3, 11.2.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-0997 or the next vulnerability affects your stack