What’s Vulnerable › Vulnerabilities
CVE-2026-100242: DataTransfer depends on phpspreadsheet version vulnerable to CVE-2026-59933 (XLS/OLE memory exhaustion)
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-29 · updated 2026-10-01
- Weakness: CWE-400
Description
Dependency on Vulnerable Third-Party Component and Uncontrolled Resource Consumption vulnerability in Wikimedia Foundation Mediawiki - DataTransfer Extension allows Excessive Allocation. This issue affects Mediawiki - DataTransfer Extension: from 1.46.0 before 1.47.0.
Affected products
- Wikimedia Foundation Mediawiki - DataTransfer Extension: from 1.46.0 before 1.47.0 — fixed in 1.47.0
How to fix
Upgrade to a fixed version: Wikimedia Foundation Mediawiki - DataTransfer Extension 1.47.0. Check the vendor advisory for mitigations.
References
- https://gerrit.wikimedia.org/r/q/Ibc4a9070c2425b690bc767a882e4c35046a39be7
- https://github.com/advisories/GHSA-xh5m-36r6-47m3
- https://phabricator.wikimedia.org/T433275
- https://github.com/advisories/GHSA-xh5m-36r6-47m3
Get alerted when CVE-2026-100242 or the next vulnerability affects your stack