What’s Vulnerable › Vulnerabilities
CVE-2026-100308: GluonTS arbitrary command execution during model deserialization
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-29 · updated 2026-09-30
- Weakness: CWE-470
Description
Deserialization of untrusted data in the model loading component in Amazon GluonTS before 0.17.0 might allow context-dependent attackers to execute arbitrary operating system commands with the privileges of the loading process via a crafted serialized model directory. To remediate this issue, users should upgrade to version 0.17.0 or later.
Affected products
- AWS gluonts: before 0.17.0 — fixed in 0.17.0
How to fix
Upgrade to a fixed version: AWS gluonts 0.17.0. Check the vendor advisory for mitigations.
References
- https://aws.amazon.com/security/security-bulletins/2026-119-aws/
- https://github.com/awslabs/gluonts/releases/tag/v0.17.0
- https://github.com/awslabs/gluonts/security/advisories/GHSA-64q6-5qv7-cwj9
Get alerted when CVE-2026-100308 or the next vulnerability affects your stack