What’s Vulnerable › Vulnerabilities
CVE-2026-100310: GNU libextractor before 1.16 Privilege Escalation via LIBEXTRACTOR_PREFIX
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-25 · updated 2026-09-30
- Weakness: CWE-426
Description
GNU libextractor before 1.16 loads plugins from an untrusted search path specified by the LIBEXTRACTOR_PREFIX environment variable without proper privilege checks. A local attacker can exploit this by setting LIBEXTRACTOR_PREFIX to a directory containing a malicious plugin that executes arbitrary code with elevated privileges when loaded by a setuid or setgid program.
Affected products
- GNU libextractor: before 1.16 — fixed in 1.16
How to fix
Upgrade to a fixed version: GNU libextractor 1.16. Check the vendor advisory for mitigations.
References
- https://ftp.gnu.org/gnu/libextractor/
- https://git.gnunet.org/gnunet/libextractor/commit/6edfa653c048800e24a17f7e8cc2bb42659b8d01.html
- https://github.com/Haitam-lazaar/libextractor-privesc
- https://www.gnu.org/software/libextractor/
- https://www.vulncheck.com/advisories/gnu-libextractor-before-1.16-privilege-escalation-via-libextractor-prefix
- http://www.openwall.com/lists/oss-security/2026/09/25/25
Get alerted when CVE-2026-100310 or the next vulnerability affects your stack