What’s Vulnerable › Vulnerabilities
CVE-2026-100376: TemplateSandbox can be abused for XSS by asking another user to preview a page with a certain sandbox prefix
- Severity: medium (CVSS 4.8 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-25 · updated 2026-09-28
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation Mediawiki - TemplateSandbox Extension allows Cross-Site Scripting (XSS). This issue affects Mediawiki - TemplateSandbox Extension: from * before 1.46.1, 1.45.5, 1.43.10.
Affected products
- Wikimedia Foundation Mediawiki - TemplateSandbox Extension: before 1.46.1, 1.45.5, 1.43.10 — fixed in 1.43.10, 1.45.5, 1.46.1
How to fix
Upgrade to a fixed version: Wikimedia Foundation Mediawiki - TemplateSandbox Extension 1.43.10, 1.45.5, 1.46.1. Check the vendor advisory for mitigations.
References
- https://gerrit.wikimedia.org/r/q/I6630b9915f640bf75c8570165eb8728bd7a2c07a
- https://phabricator.wikimedia.org/T430596
Get alerted when CVE-2026-100376 or the next vulnerability affects your stack