What’s Vulnerable › Vulnerabilities
CVE-2026-100528: OpenClaw before 2026.8.1 Credential Disclosure via Provider Endpoint
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-26 · updated 2026-09-30
- Weakness: CWE-200
Description
OpenClaw (npm package 'openclaw') before 2026.8.1 could send third-party provider credentials to the wrong endpoint. In affected versions, when a third-party provider uses an OpenAI-compatible API and the resolved model metadata lacks a concrete base URL, a pinned session that continues after a model configuration hot reload retains that provider's credential while the OpenAI SDK selects its own default endpoint. A resulting request could disclose the configured third-party provider credential to an unrelated provider endpoint and fail with a misleading authentication error. Operators who observed this condition should rotate the affected credential. The issue is fixed in 2026.8.1.
Affected products
- OpenClaw: before 2026.8.1 — fixed in 2026.8.1
How to fix
Upgrade to a fixed version: OpenClaw 2026.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-vhpg-cq3w-v8p9
- https://www.vulncheck.com/advisories/openclaw-before-2026.8.1-credential-disclosure-via-provider-endpoint
Get alerted when CVE-2026-100528 or the next vulnerability affects your stack