What’s Vulnerable › Vulnerabilities
CVE-2026-10053: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-23 · updated 2026-10-14
- Weakness: CWE-22
Description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.8 before 19.0.6, 19.1 before 19.1.4, and 19.2 before 19.2.2 that under certain conditions could have allowed an authenticated user to achieve remote code execution due to a path traversal vulnerability in the package registry.
Affected products
- GitLab: from 18.8.0 before 19.0.6; from 19.1.0 before 19.1.4; from 19.2.0 before 19.2.2 — fixed in 19.0.6, 19.1.4, 19.2.2
How to fix
Upgrade to a fixed version: GitLab 19.0.6, 19.1.4, 19.2.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-10053 or the next vulnerability affects your stack