What’s Vulnerable › Vulnerabilities
CVE-2026-100548: OpenClaw before 2026.8.1 Credential Exposure via Embedding Fallback
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-26 · updated 2026-09-30
- Weakness: CWE-200
Description
OpenClaw (npm package 'openclaw') versions >= 2026.3.28 and < 2026.8.1 contain a credential exposure issue in memory embedding failover. When remote embedding fallback is configured and the primary embedding provider fails, the request can be sent to a different fallback provider while still reusing the primary provider's configured API key, causing that credential to be transmitted as a bearer token to an unintended vendor. The practical impact depends on the configured providers, whether failover occurs, and the privileges attached to the primary provider key. The issue is fixed in 2026.8.1; as a workaround, disable cross-provider embedding fallback or configure each provider with separate, narrowly scoped credentials.
Affected products
- OpenClaw: from 2026.3.28 before 2026.8.1 — fixed in 2026.8.1
How to fix
Upgrade to a fixed version: OpenClaw 2026.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-66hm-hxq3-5pfh
- https://www.vulncheck.com/advisories/openclaw-before-2026.8.1-credential-exposure-via-embedding-fallback
Get alerted when CVE-2026-100548 or the next vulnerability affects your stack