What’s Vulnerable › Vulnerabilities
CVE-2026-100552: OpenClaw before 2026.8.1 Policy Bypass via Native Tools
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-26 · updated 2026-09-30
- Weakness: CWE-863
Description
OpenClaw (npm package 'openclaw') before 2026.8.1 does not correctly enforce per-chat tool policies for Codex app-server runtime tools. A conversation-level tools.allow rule filtered OpenClaw tools but did not restrict the shell, process, file, and patch tools owned by the Codex runtime. When a lower-trust conversation was assigned to a Codex runtime and restricted with a per-chat tool allowlist, a participant able to trigger that agent could still reach native command and file tools, bypassing the configured allowlist. The practical impact depends on the runtime's host permissions and sandbox configuration. The issue is fixed in 2026.8.1.
Affected products
- OpenClaw: before 2026.8.1 — fixed in 2026.8.1
How to fix
Upgrade to a fixed version: OpenClaw 2026.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-wwcw-jfpp-gpxw
- https://www.vulncheck.com/advisories/openclaw-before-2026.8.1-policy-bypass-via-native-tools
Get alerted when CVE-2026-100552 or the next vulnerability affects your stack