What’s Vulnerable › Vulnerabilities
CVE-2026-100570: OpenClaw before 2026.8.1 Remote Code Execution via CLOUDSDK_PYTHON_ARGS
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-26 · updated 2026-09-29
- Weakness: CWE-88
Description
OpenClaw (npm package 'openclaw') versions >= 2026.3.28 and < 2026.8.1 allow an untrusted workspace .env file to set the CLOUDSDK_PYTHON_ARGS environment variable. When an operator starts OpenClaw in attacker-controlled workspace content and then runs the Gmail setup flow, that value is inherited when gcloud is launched, and the gcloud launcher passes it as arguments to the trusted Python interpreter. A crafted CLOUDSDK_PYTHON_ARGS value can therefore cause Python to execute attacker-supplied code with the OpenClaw host user's permissions, allowing credentials to be read, files to be modified, or other processes to be started. This issue is fixed in version 2026.8.1; as a workaround, run Gmail setup only from trusted workspaces and clear inherited CLOUDSDK_* variables beforehand.
Affected products
- OpenClaw: from 2026.3.28 before 2026.8.1 — fixed in 2026.8.1
How to fix
Upgrade to a fixed version: OpenClaw 2026.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-5mrc-77hj-xjxv
- https://www.vulncheck.com/advisories/openclaw-before-2026.8.1-remote-code-execution-via-cloudsdk-python-args
Get alerted when CVE-2026-100570 or the next vulnerability affects your stack