What’s Vulnerable › Vulnerabilities
CVE-2026-100587: OpenClaw before 2026.7.1 Authorization Bypass via Codex Install
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-26 · updated 2026-09-28
- Weakness: CWE-862
Description
OpenClaw versions before 2026.7.1 fail to properly validate owner authorization in the Codex computer-use installation command. Non-owner channel senders can install arbitrary plugins and execute MCP processes with OpenClaw user privileges, affecting host confidentiality, integrity, and availability.
Affected products
- OpenClaw: before 2026.7.1 — fixed in 2026.7.1
How to fix
Upgrade to a fixed version: OpenClaw 2026.7.1. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-pjjr-5qhr-5w6r
- https://www.vulncheck.com/advisories/openclaw-before-2026.7.1-authorization-bypass-via-codex-install
Get alerted when CVE-2026-100587 or the next vulnerability affects your stack