What’s Vulnerable › Vulnerabilities
CVE-2026-100588: OpenClaw before 2026.7.1 Authentication Bypass via node.invoke
- Severity: high (CVSS 8.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-26 · updated 2026-10-05
- Weakness: CWE-863
Description
OpenClaw (npm package 'openclaw') before 2026.7.1 does not enforce the administrator scope requirement on browser control when it is reached through the node.invoke method, although direct browser.request access requires administrator scope. In Gateway deployments that honor caller identity and narrower operator scopes, a write-scoped caller with access to a connected browser-capable node can inspect pages, navigate tabs, or interact with browser-visible applications without the configured admin requirement; practical impact depends on the browser profile and signed-in state. Shared-secret token and password callers are considered fully trusted operators under OpenClaw's security model and are not affected. The issue is fixed in 2026.7.1.
Affected products
- OpenClaw: before 2026.7.1 — fixed in 2026.7.1
How to fix
Upgrade to a fixed version: OpenClaw 2026.7.1. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-jghr-xp78-995p
- https://www.vulncheck.com/advisories/openclaw-before-2026.7.1-authentication-bypass-via-node-invoke
Get alerted when CVE-2026-100588 or the next vulnerability affects your stack