What’s Vulnerable › Vulnerabilities
CVE-2026-100590: OpenClaw before 2026.7.1 Authorization Bypass via voice set
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-26 · updated 2026-09-28
- Weakness: CWE-863
Description
OpenClaw before 2026.7.1 contains an authorization bypass vulnerability in the /voice set command that allows non-owner external-channel senders to persist Gateway voice configuration. Attackers with command access can change the voice used by Talk responses for the configured provider, affecting configuration integrity without exposing credentials or granting additional host capabilities.
Affected products
- OpenClaw: before 2026.7.1 — fixed in 2026.7.1
How to fix
Upgrade to a fixed version: OpenClaw 2026.7.1. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-5j27-v2pw-cj9m
- https://www.vulncheck.com/advisories/openclaw-before-2026.7.1-authorization-bypass-via-voice-set
Get alerted when CVE-2026-100590 or the next vulnerability affects your stack