What’s Vulnerable › Vulnerabilities
CVE-2026-100632: Parse Server 9.0.0 before 9.10.1 Protected Fields Disclosure via LiveQuery
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-26 · updated 2026-09-30
- Weakness: CWE-200
Description
Parse Server is an open-source backend server. In versions >= 9.0.0 and < 9.10.1-alpha.8, and in versions < 8.6.89, LiveQuery evaluates the protectedFields class-level permission against an incompletely resolved caller identity: the subscriber's roles are not resolved, and when a subscription does not supply its own session token the event payload is redacted against an anonymous identity even though the read was authorized against the connected user. As a result, field masks defined for a role, for authenticated users, or for a specific user are not applied, so an authenticated subscriber can receive field values that the REST API correctly withholds and can use a masked field to filter or watch a subscription. Only classes with LiveQuery enabled that define protectedFields under a role:, authenticated, or per-user group are affected; masks under the public (*) group are applied correctly. The issue is fixed in 9.10.1-alpha.8 and 8.6.89. As a workaround, additionally define the affected field masks under the public (*) group, or disable LiveQuery for classes whose class-level permissions rely on role-scoped, authenticated, or per-user protectedFields groups.
Affected products
- parse-community parse-server: from 9.0.0 before 9.10.1-alpha.8; before 8.6.89 — fixed in 8.6.89, 9.10.1-alpha.8
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.89, 9.10.1-alpha.8. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/security/advisories/GHSA-9jpp-xhh6-75mf
- https://www.vulncheck.com/advisories/parse-server-9.0.0-before-9.10.1-protected-fields-disclosure-via-livequery
Get alerted when CVE-2026-100632 or the next vulnerability affects your stack