What’s Vulnerable › Vulnerabilities
CVE-2026-100652: vLLM 0.22.0 through 0.23.0 Denial of Service via stop_token_ids
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-09-26 · updated 2026-10-06
- Weakness: CWE-20
Description
vLLM versions 0.22.0 through 0.23.0 fail to validate stop_token_ids against vocabulary bounds in Rust HTTP and gRPC frontends, allowing out-of-vocabulary token IDs to reach MinTokensLogitsProcessor. Attackers can submit requests with min_tokens greater than zero and out-of-vocabulary stop_token_ids to trigger CUDA tensor indexing failures that leave EngineCore in a fatal state requiring service restart.
Affected products
- vllm-project vllm: from 0.22.0 before 0.24.0 — fixed in 0.24.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.24.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/security/advisories/GHSA-qff2-492f-9fm4
- https://www.vulncheck.com/advisories/vllm-0.22.0-through-0.23.0-denial-of-service-via-stop-token-ids
Get alerted when CVE-2026-100652 or the next vulnerability affects your stack