What’s Vulnerable › Vulnerabilities
CVE-2026-100662: Netty HTTP/3 QPACK encoder-stream unbounded memory exhaustion DoS
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-26 · updated 2026-09-30
- Weakness: CWE-400
Description
Netty's HTTP/3 codec (io.netty:netty-codec-http3) versions 4.2.0.Final through 4.2.17.Final contain an uncontrolled resource consumption vulnerability in the QPACK encoder-stream instruction decoder (QpackEncoderHandler, installed on the peer-initiated unidirectional QPACK encoder stream, type 0x02). The handler accepts an attacker-declared string-literal length of up to Integer.MAX_VALUE (~2 GiB) for the Name Length and Value Length fields of the "Insert With Literal Name" instruction (RFC 9204 §4.3.3), with no per-instruction or per-literal length cap and no cumulation-size limit; the existing HTTP/3 limits (maxHeaderListSize, maxUnknownFramePayloadLength, DEFAULT_MAX_FIELD_SECTION_SIZE) are not applied to this handler. A remote, unauthenticated peer with an established HTTP/3 connection to a default Netty HTTP/3 server can declare a very large literal length and then trickle fewer bytes than declared, causing the ByteToMessageDecoder MERGE cumulator to retain and grow the per-connection buffer, and ultimately triggering a large byte-array allocation. This leads to unbounded per-connection heap growth and OutOfMemoryError, resulting in denial of service. Fixed in 4.2.18.Final.
Affected products
- netty: from 4.2.0.Final before 4.2.18.Final — fixed in 4.2.18.Final
How to fix
Upgrade to a fixed version: netty 4.2.18.Final. Check the vendor advisory for mitigations.
References
- https://github.com/netty/netty/security/advisories/GHSA-f64r-x647-cg8w
- https://www.vulncheck.com/advisories/netty-http-3-qpack-encoder-stream-unbounded-memory-exhaustion-dos
- https://github.com/netty/netty/security/advisories/GHSA-f64r-x647-cg8w
Get alerted when CVE-2026-100662 or the next vulnerability affects your stack