What’s Vulnerable › Vulnerabilities
CVE-2026-100680: Budibase before 3.45.0 Arbitrary Local File Read via OpenAPI Import
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-26 · updated 2026-10-08
- Weakness: CWE-200
Description
Budibase versions before 3.45.0 fail to disable external JSON reference resolution in the OpenAPI/Swagger import validator, allowing authenticated builders to read arbitrary local files. Attackers with builder access can embed file:// references in OpenAPI specifications submitted to the import endpoint to exfiltrate sensitive files including environment variables containing JWT secrets, API keys, and database credentials.
Affected products
- budibase server: before 3.45.0 — fixed in 3.45.0
How to fix
Upgrade to a fixed version: budibase server 3.45.0. Check the vendor advisory for mitigations.
References
- https://github.com/Budibase/budibase/security/advisories/GHSA-8xr5-pggf-26jq
- https://www.vulncheck.com/advisories/budibase-before-3.45.0-arbitrary-local-file-read-via-openapi-import
- https://github.com/Budibase/budibase/security/advisories/GHSA-8xr5-pggf-26jq
Get alerted when CVE-2026-100680 or the next vulnerability affects your stack