What’s Vulnerable › Vulnerabilities
CVE-2026-100686: Budibase before 3.45.0 Cross-Workspace Privilege Escalation via POST /api/global/groups/:groupId/apps
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-26 · updated 2026-10-08
- Weakness: CWE-269
Description
Budibase versions before 3.45.0 fail to validate per-app authorization in the POST /api/global/groups/:groupId/apps endpoint, allowing builders to assign application roles across workspace boundaries. A builder of a single workspace can exploit missing per-app authorization checks to grant themselves admin roles in other workspaces by modifying user group role mappings.
Affected products
- budibase server: before 3.45.0 — fixed in 3.45.0
How to fix
Upgrade to a fixed version: budibase server 3.45.0. Check the vendor advisory for mitigations.
References
- https://github.com/Budibase/budibase/security/advisories/GHSA-pp5r-q4fp-mcj3
- https://www.vulncheck.com/advisories/budibase-before-3.45.0-cross-workspace-privilege-escalation-via-post-api-global-groups-groupid-apps
- https://github.com/Budibase/budibase/security/advisories/GHSA-pp5r-q4fp-mcj3
Get alerted when CVE-2026-100686 or the next vulnerability affects your stack