What’s Vulnerable › Vulnerabilities
CVE-2026-100687: Budibase Server before 3.45.0 Credential Exposure via External Table Broadcast
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-26 · updated 2026-10-08
- Weakness: CWE-200
Description
Budibase Server before 3.45.0 fails to redact plaintext datasource credentials before broadcasting external table updates to the Builder collaboration websocket room. Attackers with Builder access can intercept unredacted datasource objects containing database passwords and API keys by observing table save or delete operations.
Affected products
- budibase server: before 3.45.0 — fixed in 3.45.0
How to fix
Upgrade to a fixed version: budibase server 3.45.0. Check the vendor advisory for mitigations.
References
- https://github.com/Budibase/budibase/security/advisories/GHSA-rmv5-3xpj-w885
- https://www.vulncheck.com/advisories/budibase-server-before-3.45.0-credential-exposure-via-external-table-broadcast
Get alerted when CVE-2026-100687 or the next vulnerability affects your stack