What’s Vulnerable › Vulnerabilities
CVE-2026-100688: Budibase server before 3.45.0 Cross-Tenant Information Disclosure
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-26 · updated 2026-10-08
- Weakness: CWE-639
Description
Budibase server before 3.45.0 contains a cross-tenant information disclosure vulnerability in the GET /api/applications/:appId/appPackage endpoint that allows authenticated users to read another tenant's application metadata and source code. Attackers can supply a victim tenant's app id to retrieve sensitive application details including navigation structure, role names, internal screen URLs, JavaScript snippets, and user identifiers without authorization checks.
Affected products
- budibase server: before 3.45.0 — fixed in 3.45.0
How to fix
Upgrade to a fixed version: budibase server 3.45.0. Check the vendor advisory for mitigations.
References
- https://github.com/Budibase/budibase/security/advisories/GHSA-4946-qf2m-wrh5
- https://www.vulncheck.com/advisories/budibase-server-before-3.45.0-cross-tenant-information-disclosure
- https://github.com/Budibase/budibase/security/advisories/GHSA-4946-qf2m-wrh5
Get alerted when CVE-2026-100688 or the next vulnerability affects your stack