What’s Vulnerable › Vulnerabilities
CVE-2026-100695: Adminer before 6.0.2 XSS via CONNECTION_ID escalating to RCE
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-26 · updated 2026-09-28
- Weakness: CWE-79
Description
Adminer before 6.0.2 contains a cross-site scripting vulnerability where the CONNECTION_ID() database result is interpolated into JavaScript without proper escaping, allowing a malicious database server to execute arbitrary JavaScript in the authenticated Adminer origin. In co-located deployments where the database has FILE privileges and can write to the webroot, attackers can use the XSS to submit authenticated SQL requests that write PHP files via INTO DUMPFILE, achieving remote code execution as the web server account.
Affected products
- vrana adminer: before 6.0.2 — fixed in 6.0.2
How to fix
Upgrade to a fixed version: vrana adminer 6.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/vrana/adminer/security/advisories/GHSA-7c5h-q78c-fpxx
- https://www.vulncheck.com/advisories/adminer-before-6.0.2-xss-via-connection-id-escalating-to-rce
- https://github.com/vrana/adminer/security/advisories/GHSA-7c5h-q78c-fpxx
Get alerted when CVE-2026-100695 or the next vulnerability affects your stack