What’s Vulnerable › Vulnerabilities
CVE-2026-100744: coollabsio Coolify Route-Level Middleware CanUpdateResource.php authorization
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-27 · updated 2026-09-30
- Weakness: CWE-862
Description
A flaw has been found in coollabsio Coolify up to 4.1.2. The affected element is an unknown function of the file app/Http/Middleware/CanUpdateResource.php of the component Route-Level Middleware. Executing a manipulation can lead to missing authorization. The attack may be launched remotely. The exploit has been published and may be used. Upgrading to version 4.2.0 is sufficient to fix this issue. This patch is called 39ae16de4248075de8c08f3259114e064b20d52d. It is advisable to upgrade the affected component.
Affected products
- coollabsio coolify: 4.1.0, 4.1.1, 4.1.2
References
- https://github.com/coollabsio/coolify/
- https://github.com/coollabsio/coolify/commit/39ae16de4248075de8c08f3259114e064b20d52d
- https://github.com/coollabsio/coolify/pull/10829
- https://github.com/coollabsio/coolify/releases/tag/v4.2.0
- https://github.com/lakshayyverma/CVE-Discovery/blob/main/coolify-missing-authorization-route-middleware.7z
- https://vuldb.com/cve/CVE-2026-100744
- https://vuldb.com/submit/897358
- https://vuldb.com/vuln/410615
- https://vuldb.com/vuln/410615/cti
Get alerted when CVE-2026-100744 or the next vulnerability affects your stack