What’s Vulnerable › Vulnerabilities

CVE-2026-10080: Boards plugin panics on WebSocket command with non-string field types

Description

Mattermost versions 11.7.x <= 11.7.6, 10.11.x <= 10.11.21, 11.8.x <= 11.8.3 fails to validate WebSocket command field types which allows an authenticated user to crash the plugin process and deny service to all Boards users via a custom_focalboard_SUBSCRIBE_TEAM message with a non-string teamId.. Mattermost Advisory ID: MMSA-2026-00687

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.11.22, 11.7.7, 11.8.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-10080 or the next vulnerability affects your stack