What’s Vulnerable › Vulnerabilities
CVE-2026-10083: APCu Manager < 4.5.0 - Unauthenticated Stored XSS via Cache Key Pollution
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-29 · updated 2026-06-29
Description
The APCu Manager WordPress plugin before 4.5.0 does not escape APCu object-cache keys before rendering them in an admin-area page, leading to a Stored Cross-Site Scripting vulnerability. When a persistent object cache is enabled, cache keys derived from unsanitised user input (e.g. a transient name created by another APCu Manager WordPress plugin before 4.5.0 from an unauthenticated request) are output without escaping and execute arbitrary JavaScript in the session of an administrator viewing the page.
Affected products
- APCu Manager: before 4.5.0 — fixed in 4.5.0
How to fix
Upgrade to a fixed version: APCu Manager 4.5.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-10083 or the next vulnerability affects your stack