What’s Vulnerable › Vulnerabilities
CVE-2026-100844: MONAI before 1.6.0 OS Command Injection via dataset_name_or_id
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-09-27 · updated 2026-09-30
- Weakness: CWE-78
Description
MONAI before 1.6.0 is vulnerable to OS command injection in the nnUNetV2Runner component (monai.apps.nnunet.nnunetv2_runner). User-controlled values taken from the YAML configuration file (notably dataset_name_or_id) and from CLI/kwargs arguments are concatenated into a command string without quoting or validation and then passed to subprocess with shell=True, so shell metacharacters (e.g., ';' on Linux, '&' on Windows) are interpreted. If a victim loads and processes a crafted configuration file — for example by instantiating nnUNetV2Runner with the malicious YAML and invoking a training/validation job such as train_single_model() — arbitrary commands are executed with the privileges of the user running the job.
Affected products
- Project-MONAI MONAI: before 1.6.0 — fixed in 1.6.0
How to fix
Upgrade to a fixed version: Project-MONAI MONAI 1.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/Project-MONAI/MONAI/security/advisories/GHSA-rghg-q7wp-9767
- https://www.vulncheck.com/advisories/monai-before-1.6.0-os-command-injection-via-dataset-name-or-id
- https://github.com/Project-MONAI/MONAI/security/advisories/GHSA-rghg-q7wp-9767
Get alerted when CVE-2026-100844 or the next vulnerability affects your stack