What’s Vulnerable › Vulnerabilities
CVE-2026-100845: MONAI before 1.6.0 Remote Code Execution via NumpyReader
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-09-27 · updated 2026-09-30
- Weakness: CWE-502
Description
MONAI before 1.6.0 contains an unsafe deserialization vulnerability in the NumpyReader class that unconditionally uses numpy.load with allow_pickle=True when loading .npy and .npz files. Attackers can craft malicious .npy files with pickle payloads that execute arbitrary code when loaded through MONAI's standard data pipeline.
Affected products
- Project-MONAI MONAI: before 1.6.0 — fixed in 1.6.0
How to fix
Upgrade to a fixed version: Project-MONAI MONAI 1.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/Project-MONAI/MONAI/security/advisories/GHSA-wg9g-w2j2-8pgr
- https://www.vulncheck.com/advisories/monai-before-1.6.0-remote-code-execution-via-numpyreader
- https://github.com/Project-MONAI/MONAI/security/advisories/GHSA-wg9g-w2j2-8pgr
Get alerted when CVE-2026-100845 or the next vulnerability affects your stack