What’s Vulnerable › Vulnerabilities

CVE-2026-10086: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Description

GitLab has remediated an issue in GitLab EE affecting all versions from 16.4 before 18.11.6, 19.0 before 19.0.3, and 19.1 before 19.1.1 that under certain conditions could have allowed an authenticated user with developer-role permissions to execute arbitrary client-side code in the context of another user's session, due to improper sanitization of user-supplied input.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.11.6, 19.0.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-10086 or the next vulnerability affects your stack