What’s Vulnerable › Vulnerabilities
CVE-2026-100864: heym before 0.0.91 Remote Code Execution via Expression Engine
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-27 · updated 2026-09-28
- Weakness: CWE-94
Description
heym before 0.0.91 contains a sandbox escape vulnerability in the expression engine's DotList map/filter and fallback resolver that allows authenticated users to execute arbitrary Python code. Attackers can craft workflow expressions using dunder attribute access through item expressions or the fallback resolver to access os.system and execute commands as the backend process.
Affected products
- heymrun heym: before 0.0.91 — fixed in 0.0.91
How to fix
Upgrade to a fixed version: heymrun heym 0.0.91. Check the vendor advisory for mitigations.
References
- https://github.com/heymrun/heym/security/advisories/GHSA-87x2-9jwx-7gh4
- https://www.vulncheck.com/advisories/heym-before-0.0.91-remote-code-execution-via-expression-engine
- https://github.com/heymrun/heym/security/advisories/GHSA-87x2-9jwx-7gh4
Get alerted when CVE-2026-100864 or the next vulnerability affects your stack