What’s Vulnerable › Vulnerabilities
CVE-2026-100865: Heym before 0.0.53 Remote Code Execution via eval() Sandbox Escape
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-27 · updated 2026-09-28
- Weakness: CWE-94
Description
Heym before 0.0.53 evaluates workflow condition expressions using Python's eval() with insufficient sandboxing in the workflow executor service. Authenticated users can edit workflow condition nodes or import malicious templates to execute arbitrary Python and OS commands as the backend process user.
Affected products
- heymrun heym: before 0.0.53 — fixed in 0.0.53
How to fix
Upgrade to a fixed version: heymrun heym 0.0.53. Check the vendor advisory for mitigations.
References
- https://github.com/heymrun/heym/commit/341d1012367cd74f85c617e1c98dd49e3fcb5e83
- https://github.com/heymrun/heym/security/advisories/GHSA-pm6h-x3h5-j38h
- https://github.com/heymrun/heym/security/advisories/GHSA-pm6h-x3h5-j38h
Get alerted when CVE-2026-100865 or the next vulnerability affects your stack