What’s Vulnerable › Vulnerabilities
CVE-2026-100868: Penpot before 2.18.0 Unauthenticated WebSocket Access via MCP Bridge
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-27 · updated 2026-10-08
- Weakness: CWE-1327
Description
Penpot before 2.18.0 binds the MCP server plugin WebSocket bridge to all network interfaces without authentication in single-user mode. Unauthenticated attackers on adjacent networks can connect to the WebSocket port to impersonate the Penpot browser plugin, intercept task payloads, and return forged results to the MCP client.
Affected products
- penpot: before 2.18.0 — fixed in 2.18.0
- penpot @penpot/mcp: through 2.15.4
How to fix
Upgrade to a fixed version: penpot 2.18.0. Check the vendor advisory for mitigations.
References
- https://github.com/penpot/penpot
- https://github.com/penpot/penpot/blob/1d2c37e52c733f74017d90b0fd1ae2d074a5c33d/mcp/packages/server/src/PluginBridge.ts#L52
- https://github.com/penpot/penpot/commit/b5274a44766d095247037be18c1d1918ac67ddeb
- https://github.com/penpot/penpot/security/advisories/GHSA-22qr-rp27-j9wm
- https://github.com/penpot/penpot/security/advisories/GHSA-ch2q-6x56-qg5r
- https://www.vulncheck.com/advisories/penpot-before-2.18.0-unauthenticated-websocket-access-via-mcp-bridge
- https://github.com/penpot/penpot/security/advisories/GHSA-ch2q-6x56-qg5r
Get alerted when CVE-2026-100868 or the next vulnerability affects your stack