What’s Vulnerable › Vulnerabilities

CVE-2026-10087: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Description

GitLab has remediated an issue in GitLab EE affecting all versions from 17.1 before 18.10.8, 18.11 before 18.11.5, and 19.0 before 19.0.2 that under certain conditions could have allowed an authenticated user with developer-role permissions to execute arbitrary client-side code on behalf of a targeted user due to improper input sanitization in the Analytics Dashboard.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.10.8, 18.11.5, 19.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-10087 or the next vulnerability affects your stack