What’s Vulnerable › Vulnerabilities
CVE-2026-100871: Sylius before 1.12.25, 1.13.17, 1.14.20, 2.1.16, and 2.2.9 JWT Audience Confusion Allows Admin API Authentication
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-27 · updated 2026-09-30
- Weakness: CWE-287
Description
Sylius versions before 1.12.25, 1.13.17, 1.14.20, 2.1.16, and 2.2.9 fail to include firewall identification in JWT tokens issued by separate Admin and Shop API endpoints. Attackers can register a shop customer account using an administrator's email address and obtain a token that the Admin API resolves to that administrator, granting full administrative access.
Affected products
- Sylius: from 1.11.0 before 1.12.25; from 1.13.0 before 1.13.17; from 1.14.0 before 1.14.20; from 2.0.0 before 2.1.16; from 2.2.0 before 2.2.9 — fixed in 1.12.25, 1.13.17, 1.14.20, 2.1.16, 2.2.9
How to fix
Upgrade to a fixed version: Sylius 1.12.25, 1.13.17, 1.14.20, 2.1.16. Check the vendor advisory for mitigations.
References
- https://github.com/Sylius/Sylius
- https://github.com/Sylius/Sylius/commit/cdfb672a4d174eb2c73159b25cf5b5f44088f45c
- https://github.com/Sylius/Sylius/pull/19213
- https://github.com/Sylius/Sylius/releases/tag/v2.2.9
- https://github.com/Sylius/Sylius/security/advisories/GHSA-f6mx-qxjc-55xf
- https://www.vulncheck.com/advisories/sylius-before-1.12.25-1.13.17-1.14.20-2.1.16-and-2.2.9-jwt-audience-confusion-allows-admin-api-authentication
Get alerted when CVE-2026-100871 or the next vulnerability affects your stack