What’s Vulnerable › Vulnerabilities
CVE-2026-101025: NGINX ngx_http_js_module vulnerability
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-15
- Weakness: CWE-401
Description
Description NGINX JavaScript (njs) has a vulnerability where the built-in njs engine leaks a libxml2 parser context when xml.parse() fails. The failure path did not register cleanup and the context was not released for the lifetime of the process. An unauthenticated attacker may send requests with malformed XML and can cause unbounded memory growth in long-lived NGINX worker processes. Impact This vulnerability may allow remote attackers to send requests that trigger repeated parsing of malformed XML and may lead to NGINX worker termination or denial of service. There is no control plane exposure; this is a data plane issue only. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 NGINX JavaScript: from 0.7.10 before 1.0.2 — fixed in 1.0.2
How to fix
Upgrade to a fixed version: F5 NGINX JavaScript 1.0.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-101025 or the next vulnerability affects your stack