What’s Vulnerable › Vulnerabilities
CVE-2026-101043: pnpm 11.0.0 before 11.11.0 Environment Variable Exfiltration via Proxy Settings
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-27 · updated 2026-09-30
- Weakness: CWE-201
Description
pnpm versions 11.0.0 before 11.11.0 and 10.7.0 before 10.34.5 expand ${VAR} environment-variable placeholders in the httpProxy, httpsProxy, and noProxy settings read from a project's pnpm-workspace.yaml. Because the manifest is repository-controlled and the proxy keys were omitted from the request-destination key set that otherwise suppresses placeholder expansion for untrusted manifests (as already done for registry, pnprServer, registries and namedRegistries), an attacker who controls a repository's pnpm-workspace.yaml can cause a victim who clones the repository and runs a pnpm command (e.g. pnpm install) to expand environment secrets such as NPM_TOKEN or GITHUB_TOKEN into a proxy hostname or userinfo and route install traffic — and the corresponding DNS lookups — through an attacker-controlled host. The exfiltration occurs during configuration loading, before any lifecycle script executes. Fixed in pnpm 11.11.0 and 10.34.5.
Affected products
- pnpm: from 11.0.0 before 11.11.0; from 10.7.0 before 10.34.5 — fixed in 10.34.5, 11.11.0
How to fix
Upgrade to a fixed version: pnpm 10.34.5, 11.11.0. Check the vendor advisory for mitigations.
References
- https://github.com/pnpm/pnpm/security/advisories/GHSA-vx52-2968-3vc6
- https://www.vulncheck.com/advisories/pnpm-11.0.0-before-11.11.0-environment-variable-exfiltration-via-proxy-settings
- https://github.com/pnpm/pnpm/security/advisories/GHSA-vx52-2968-3vc6
Get alerted when CVE-2026-101043 or the next vulnerability affects your stack