What’s Vulnerable › Vulnerabilities
CVE-2026-101048: Cloudreve before 4.17.0 SSRF via Admin.Read OAuth scope
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-27 · updated 2026-10-08
- Weakness: CWE-863
Description
Cloudreve before 4.17.0 registers the administrative node test endpoints (POST /api/v4/admin/node/test and POST /api/v4/admin/node/test/downloader) without requiring the Admin.Write OAuth scope, unlike the node create/update/delete routes. An OAuth client that has been authorized by an administrator with only the Admin.Read scope can therefore submit attacker-controlled node definitions and cause the Cloudreve server to issue outbound requests to arbitrary URLs, enabling blind server-side request forgery, internal service probing, and delivery of signed Cloudreve slave-style requests to attacker-chosen endpoints.
Affected products
- cloudreve: before 4.17.0 — fixed in 4.17.0
How to fix
Upgrade to a fixed version: cloudreve 4.17.0. Check the vendor advisory for mitigations.
References
- https://github.com/cloudreve/cloudreve/security/advisories/GHSA-v6w6-358x-2433
- https://www.vulncheck.com/advisories/cloudreve-before-4.17.0-ssrf-via-admin-read-oauth-scope
- https://github.com/cloudreve/cloudreve/security/advisories/GHSA-v6w6-358x-2433
Get alerted when CVE-2026-101048 or the next vulnerability affects your stack