What’s Vulnerable › Vulnerabilities
CVE-2026-101085: Nezha before 2.3.8 Denial of Service via Alert Rule
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-27 · updated 2026-09-28
- Weakness: CWE-197
Description
Nezha before 2.3.8 fails to validate alert rule type and duration bounds, allowing authenticated non-administrator users to create malformed rules that trigger unrecovered panics in the alert evaluator goroutine. Attackers can submit a crafted alert rule via the POST /api/v1/alert-rule endpoint to crash the dashboard process, which persists the rule and causes repeated crashes on restart, disabling all monitoring and control plane functionality.
Affected products
- nezhahq nezha: before 2.3.8 — fixed in 2.3.8
How to fix
Upgrade to a fixed version: nezhahq nezha 2.3.8. Check the vendor advisory for mitigations.
References
- https://github.com/nezhahq/nezha/security/advisories/GHSA-2qc6-x993-hjq9
- https://www.vulncheck.com/advisories/nezha-before-2.3.8-denial-of-service-via-alert-rule
- https://github.com/nezhahq/nezha/security/advisories/GHSA-2qc6-x993-hjq9
Get alerted when CVE-2026-101085 or the next vulnerability affects your stack