What’s Vulnerable › Vulnerabilities
CVE-2026-101169
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-29 · updated 2026-09-29
- Weakness: CWE-502
Description
In affected versions of Octopus Server, an authenticated user with permissions to edit an Environment or Project can set specifically crafted JSON content for the object. Insecure deserialization of this content allows the user to execute arbitrary code in the Octopus Server process.
Affected products
- Octopus Deploy Octopus Server: from 2019.4.1 before 2026.1.11781; from 2026.2.0 before 2026.2.13441; from 2026.3.0 before 2026.3.15829 — fixed in 2026.1.11781, 2026.2.13441, 2026.3.15829
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2026.1.11781, 2026.2.13441, 2026.3.15829. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-101169 or the next vulnerability affects your stack