What’s Vulnerable › Vulnerabilities
CVE-2026-10142: kafka-python prior to 2.3.2 Denial of Service via Protocol Parser Frame Length
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-10 · updated 2026-10-08
- Weakness: CWE-789
Description
kafka-python prior to 2.3.2 contains a denial-of-service vulnerability in the protocol parser that allows a malicious broker or machine-in-the-middle attacker to exhaust memory or hang connections by sending a crafted 4-byte frame length value without bounds validation. Attackers can send a specially crafted frame length through the receive_bytes() function to trigger either a multi-gigabyte memory allocation or an uncaught ValueError that leaves the connection in a broken state, causing requests to hang and consumers to stop heartbeating until restart.
Affected products
- Dpkp Kafka-Python: before 2.3.2 — fixed in 2.3.2
How to fix
Upgrade to a fixed version: Dpkp Kafka-Python 2.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/dpkp/kafka-python/commit/6e4831444f972d169cdd11f5c8d50333cea3f19b
- https://github.com/dpkp/kafka-python/pull/3019
- https://github.com/dpkp/kafka-python/pull/3026
- https://www.vulncheck.com/advisories/kafka-python-prior-to-denial-of-service-via-protocol-parser-frame-length
Get alerted when CVE-2026-10142 or the next vulnerability affects your stack