What’s Vulnerable › Vulnerabilities
CVE-2026-101889: Prime Mover < 2.2.1 Path Traversal via wprime-config.json
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-01 · updated 2026-10-02
- Weakness: CWE-22
Description
The Prime Mover plugin for WordPress before 2.2.1 contains a path traversal vulnerability that allows authenticated administrators to delete arbitrary directories by importing a crafted WPRIME/TAR package with manipulated tar_root_folder values in wprime-config.json. Attackers can exploit insufficient path validation in computeExtractVariables() and validateImportedSiteVsPackage() to cause primeMoverDoDelete() to remove directories outside the intended extraction path, potentially deleting critical WordPress directories such as wp-admin and rendering the site inoperable.
Affected products
- Codexonics Prime Mover: before 2.2.1 — fixed in 2.2.1
How to fix
Upgrade to a fixed version: Codexonics Prime Mover 2.2.1. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/prime-mover/#developers
- https://www.vulncheck.com/advisories/prime-mover-path-traversal-via-wprime-config-json
Get alerted when CVE-2026-101889 or the next vulnerability affects your stack