What’s Vulnerable › Vulnerabilities
CVE-2026-101890: Prime Mover < 2.2.1 Stored XSS via Package Metadata
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-01 · updated 2026-10-02
- Weakness: CWE-79
Description
The Prime Mover plugin for WordPress before 2.2.1 contains a stored cross-site scripting vulnerability that allows attackers to execute arbitrary JavaScript by injecting an unescaped site_title value in a package's footprint.json file. Attackers can place a crafted package under the prime-mover-export-files directory so that the malicious value renders unescaped in the column_site_title() method of PrimeMoverBackupMenuListTable.php, triggering script execution in an administrator's browser when they view the Prime Mover Packages list table without needing to restore the package.
Affected products
- Codexonics Prime Mover: before 2.2.1 — fixed in 2.2.1
How to fix
Upgrade to a fixed version: Codexonics Prime Mover 2.2.1. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/prime-mover/#developers
- https://www.vulncheck.com/advisories/prime-mover-stored-xss-via-package-metadata
Get alerted when CVE-2026-101890 or the next vulnerability affects your stack