What’s Vulnerable › Vulnerabilities
CVE-2026-101986: Junos OS and Junos OS Evolved: J-Web permits pre-authentication CGI execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-30
- Weakness: CWE-287
Description
An Improper Authentication vulnerability in J-Web of Juniper Networks Junos OS and Junos OS Evolved allows an unauthenticated network attacker to bypass J-Web authentication and execute CGI content with elevated privileges via a crafted HTTP request.
Affected products
- Juniper Junos OS: through 23.1; 23.2-r1, 23.2-r1-s1, 23.2-r1-s2, 23.2-r2, 23.2-r2-s1, 23.2-r2-s2 (+44); 23.2, 23.4, 24.2, 24.4, 25.2, 25.4 (+1)
- Juniper Networks Junos OS Evolved: through 23.1; 23.2-r1, 23.2-r1-s1, 23.2-r1-s2, 23.2-r2, 23.2-r2-s1, 23.2-r2-s2 (+49); 23.2, 23.4, 23.4x100, 24.2, 24.4, 25.2 (+2)
- Juniper Junos OS: before 23.2R2-S7.7; from 23.4 before 23.4R2-S8.13; from 24.2 before 24.2R2-S5.5; from 24.4 before 24.4R2-S5; from 25.2 before 25.2R2-S2; from 25.4 before 25.4R1-S3 — fixed in 23.2R2-S7.7, 23.4R2-S8.13, 24.2R2-S5.5, 24.4R2-S5, 25.2R2-S2, 25.4R1-S3
- Juniper Networks Junos OS Evolved: before 23.2R2-S7.7-EVO; from 23.4 before 23.4R2-S8.11-EVO; from 24.2 before 24.2R2-S5.6-EVO; from 24.4 before 24.4R2-S5-EVO; from 25.2 before 25.2R2-S2-EVO; from 25.4 before 25.4R1-S3-EVO — fixed in 23.2R2-S7.7-EVO, 23.4R2-S8.11-EVO, 24.2R2-S5.6-EVO, 24.4R2-S5-EVO, 25.2R2-S2-EVO, 25.2X100-D35-EVO
How to fix
Upgrade to a fixed version: Juniper Junos OS 23.2R2-S7.7, 23.4R2-S8.13, 24.2R2-S5.5, 24.4R2-S5; Juniper Networks Junos OS Evolved 23.2R2-S7.7-EVO, 23.4R2-S8.11-EVO, 24.2R2-S5.6-EVO, 24.4R2-S5-EVO. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-101986 or the next vulnerability affects your stack