What’s Vulnerable › Vulnerabilities
CVE-2026-102087: Junos OS and Junos OS Evolved: If in a traffic engineering scenario a specific valid BGP-LS attribute is received rpd crashes
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-15
- Weakness: CWE-184
Description
An Incomplete List of Disallowed Inputs vulnerability in the routing protocol daemon (rpd) of Juniper Networks Junos OS and Junos OS Evolved allows an unauthenticated, adjacent attacker to cause a Denial-of-Service (DoS). When in a BGP traffic engineering scenario a specific, valid, optional, non-transitive BGP update is received over an established BGP session, RPD crashes and automatically restarts, which leads to traffic impact until routing has reconverged. This issue affects: Junos OS: * All versions before 23.2R2-S6; * 23.4 versions before 23.4R2-S7; * 24.2 versions before 24.2R2-S4; * 24.4 versions before 24.4R2-S4; * 25.2 versions before 25.2R1-S2, 25.2R2; Junos OS Evolved: * All versions before 23.2R2-S6-EVO; * 23.4 versions before 23.4R2-S8.11-EVO; * 24.2 versions before 24.2R2-S4-EVO; * 24.4 versions before 24.4R2-S5-EVO; * 25.2 versions before 25.2R1-S2-EVO, 25.2R2-EVO;
Affected products
- Juniper Junos OS: before 23.2R2-S6; from 23.4 before 23.4R2-S7; from 24.2 before 24.2R2-S4; from 24.4 before 24.4R2-S4; from 25.2 before 25.2R1-S2, 25.2R2 — fixed in 25.2R2, 23.2R2-S6, 23.4R2-S7, 24.2R2-S4, 24.4R2-S4, 25.2R1-S2
- Juniper Networks Junos OS Evolved: before 23.2R2-S6-EVO; from 23.4 before 23.4R2-S8.11-EVO; from 24.2 before 24.2R2-S4-EVO; from 24.4 before 24.4R2-S5-EVO; from 25.2 before 25.2R1-S2-EVO, 25.2R2-EVO — fixed in 25.2R2-EVO, 23.2R2-S6-EVO, 23.4R2-S8.11-EVO, 24.2R2-S4-EVO, 24.4R2-S5-EVO, 25.2R1-S2-EVO
How to fix
Upgrade to a fixed version: Juniper Junos OS 25.2R2, 23.2R2-S6, 23.4R2-S7, 24.2R2-S4; Juniper Networks Junos OS Evolved 25.2R2-EVO, 23.2R2-S6-EVO, 23.4R2-S8.11-EVO, 24.2R2-S4-EVO. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-102087 or the next vulnerability affects your stack