What’s Vulnerable › Vulnerabilities
CVE-2026-102096: Kiteworks Core OS command injection
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-30 · updated 2026-10-07
- Weakness: CWE-78
Description
Kiteworks Core before version 9.5.0 is vulnerable to OS Command Injection that allows an authenticated administrator to upload a configuration package whose contents were not sufficiently validated before being processed. A crafted package could cause the underlying system to execute arbitrary operating-system commands, potentially with elevated privileges, on the affected appliance.
Affected products
- Kiteworks Email Protection Gateway: before 9.5.0 — fixed in 9.5.0
How to fix
Upgrade to a fixed version: Kiteworks Email Protection Gateway 9.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/kiteworks/security-advisories/security/advisories/GHSA-c3wx-5mx6-2qpg
- https://raw.githubusercontent.com/cisagov/CSAF/develop/csaf_files/VA/white/2026/va-26-274-01.json
Get alerted when CVE-2026-102096 or the next vulnerability affects your stack