What’s Vulnerable › Vulnerabilities
CVE-2026-102100: Kiteworks Core stored XSS
- Severity: high (CVSS 8.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-30 · updated 2026-10-07
- Weakness: CWE-79
Description
Kiteworks Core before version 9.5.0 is vulnerable to Stored Cross-Site Scripting. A stored cross-site scripting (XSS) weakness in Kiteworks Core could allow an authenticated user to submit content that, when later viewed by another user, executes arbitrary JavaScript in that user's authenticated session. This could be used to perform actions on the victim's behalf and may have permitted account takeover, including of higher-privileged users. Exploitation requires the victim to view the attacker-supplied content.
Affected products
- Kiteworks Email Protection Gateway: before 9.5.0 — fixed in 9.5.0
How to fix
Upgrade to a fixed version: Kiteworks Email Protection Gateway 9.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/kiteworks/security-advisories/security/advisories/GHSA-vr65-9jwc-jgjx
- https://raw.githubusercontent.com/cisagov/CSAF/develop/csaf_files/VA/white/2026/va-26-274-01.json
Get alerted when CVE-2026-102100 or the next vulnerability affects your stack