What’s Vulnerable › Vulnerabilities
CVE-2026-102407: Incorrect Authorization in Elasticsearch Leading to Unauthorized Data Stream Modification
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-06 · updated 2026-10-13
- Weakness: CWE-863
Description
Incorrect Authorization (CWE-863) in Elasticsearch can lead to unauthorized data stream modification via Accessing Functionality Not Properly Constrained by ACLs (CAPEC-1). An authenticated user with sufficient privileges over a single resource could use the Modify Data Streams API to modify a data stream to which they were not otherwise authorized, potentially injecting data into it or affecting its ability to be searched normally. This issue does not allow an attacker to read the contents of a data stream they do not otherwise have access to.
Affected products
- Elasticsearch: from 7.17.5 through 7.17.29; from 8.2.2 before 8.19.19; from 9.0.0 before 9.3.8; from 9.4.0 before 9.4.4 — fixed in 8.19.19, 9.3.8, 9.4.4
How to fix
Upgrade to a fixed version: Elasticsearch 8.19.19, 9.3.8, 9.4.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-102407 or the next vulnerability affects your stack